Content negotiation sluggish
Incident Report for Crossref
Resolved
This issue was caused by use of the query.title feature on the REST API by a few users. Because of the way it's implemented, it seems to be degrading the performance of the REST API on all pools in which it’s used (public, polite and plus) and all related services, including Content Negotiation. We've now put a block on the query.title function and Content Negotiation is now stable - see https://0-status-crossref-org.lib.rivier.edu/incidents/4y45gj63jsp4 for more information.
Posted Oct 16, 2019 - 19:11 UTC
Identified
Our content negotiation service has been sluggish for the past few hours. This seems to be due to heavy usage from a single user. We're working with the relevant user and hope to return the service to normal performance very soon.
Posted Oct 14, 2019 - 14:09 UTC
This incident affected: APIs (Content negotiation).