Email confirmations not being delivered for test deposit system
Incident Report for Crossref
Resolved
This incident has been resolved.
Posted Nov 04, 2019 - 17:07 UTC
Identified
Email confirmations from our test deposit system (test.crossref.org) are not currently being delivered. We're working on a fix.
Posted May 24, 2019 - 18:42 UTC
This incident affected: Content Registration (Test deposit system).